Skip to main content
← All vulnerabilities
CVE-2026-26233GO-2026-4916GHSA-247X-7QW8-FP98

Denial of Service via HTTP/2 single packet attack on login endpoint

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 10.11.12+incompatible, 11.2.4+incompatible, 11.3.2+incompatible, 11.4.1+incompatible, 11.4.1, and 3 more
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Mattermost versions 11.4.x <= 11.4.0, 11.3.x <= 11.3.1, 11.2.x <= 11.2.3, 10.11.x <= 10.11.11 fail to rate limit login requests which allows unauthenticated remote attackers to cause denial of service (server crash and restart) via HTTP/2 single packet attack with 100+ parallel login requests.. Mattermost Advisory ID: MMSA-2025-00566

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Mattermost Mattermost

    From 11.4.0 · through 11.4.0; From 11.3.0 · through 11.3.1; From 11.2.0 · through 11.2.3; From 10.11.0 · through 10.11.11

  • github.com/mattermost/mattermost-serverGo

    From 10.11.0-rc1+incompatible · fixed in 10.11.12+incompatible; From 11.2.0-rc1+incompatible · fixed in 11.2.4+incompatible; From 11.3.0-rc1+incompatible · fixed in 11.3.2+incompatible; From 11.4.0-rc1+incompatible · fixed in 11.4.1+incompatible

  • github.com/mattermost/mattermost-serverGo

    From 11.4.0-rc1 · fixed in 11.4.1

  • github.com/mattermost/mattermost-serverGo

    From 11.3.0-rc1 · fixed in 11.3.2

  • github.com/mattermost/mattermost-serverGo

    From 11.2.0-rc1 · fixed in 11.2.4

  • github.com/mattermost/mattermost-serverGo

    From 10.11.0-rc1 · fixed in 10.11.12

References 1

mattermost.com