CVE-2026-25958GHSA-V226-32C7-X2V7
Cube privilege escalation via a specially crafted request
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.0.14, 1.4.2, 1.5.13
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
Cube is a semantic layer for building data applications. From 0.27.19 to before 1.5.13, 1.4.2, and 1.0.14, it is possible to make a specially crafted request with a valid API token that leads to privilege escalation. This vulnerability is fixed in 1.5.13, 1.4.2, and 1.0.14.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- cube-js cube
From 0.27.19 · fixed in 1.0.14; From 1.1.0 · fixed in 1.4.2; From 1.5.0 · fixed in 1.5.13
- @cubejs-backend/server-corenpm
From 0.27.19 · fixed in 1.0.14
- @cubejs-backend/server-corenpm
From 1.1.0 · fixed in 1.4.2
- @cubejs-backend/server-corenpm
From 1.5.0 · fixed in 1.5.13