Skip to main content
← All vulnerabilities
CVE-2026-24784GHSA-JJWG-4948-6WXP

DotNetNuke.Core has a potential XSS vulnerability in modules' header and footer

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 9.13.10, 10.2.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

DNN (formerly DotNetNuke) is an open-source web content management platform (CMS) in the Microsoft ecosystem. Starting in version 9.0.0 and prior to versions 9.13.10 and 10.2.0, a content editor could inject scripts in module headers/footers that would run for other users. Versions 9.13.10 and 10.2.0 contain a fix for the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • dnnsoftware Dnn.Platform

    From 9.0.0 · fixed in 9.13.10; From 10.0.0 · fixed in 10.2.0

  • DotNetNuke.CoreNuGet

    From 9.0.0 · fixed in 9.13.10

  • DotNetNuke.CoreNuGet

    From 10.0.0 · fixed in 10.2.0

References 1

GitHub · dnnsoftware/Dnn.Platform