Skip to main content
← All vulnerabilities
CVE-2026-24733GHSA-QQ5R-98HH-RXC9BIT-TOMCAT-2026-24733

Apache Tomcat: Security constraint bypass with HTTP/0.9

Published
Last modified
published
Not listed in CISA KEV
Low (apache)
Fix
Fixed in 11.0.15, 10.1.50, 9.0.113
1 proof of concept on GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Improper Input Validation vulnerability in Apache Tomcat. Tomcat did not limit HTTP/0.9 requests to the GET method. If a security constraint was configured to allow HEAD requests to a URI but deny GET requests, the user could bypass that constraint on GET requests by sending a (specification invalid) HEAD request using HTTP/0.9. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0.M1 through 9.0.112. Older, EOL versions are also affected. Users are recommended to upgrade to version 11.0.15 or later, 10.1.50 or later or 9.0.113 or later, which fixes the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache Tomcat

    From 11.0.0-M1 · through 11.0.14; From 10.1.0-M1 · through 10.1.49; From 9.0.0.M1 · through 9.0.112; through 8.5.100

  • org.apache.tomcat:tomcat-coyoteMaven

    From 11.0.0-M1 · fixed in 11.0.15

  • org.apache.tomcat:tomcat-coyoteMaven

    From 10.1.0-M1 · fixed in 10.1.50

  • org.apache.tomcat:tomcat-coyoteMaven

    fixed in 9.0.113

References 2

lists.apache.org

GitHub · Darabium/CVE-2026-24733