Skip to main content
← All vulnerabilities
CVE-2026-24713GHSA-6W48-2G9J-V9Q5

Apache IoTDB: JEXL Expression Injection Vulnerability

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.3.7, 2.0.7
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

Improper Input Validation vulnerability in Apache IoTDB. This issue affects Apache IoTDB: from 1.0.0 before 1.3.7, from 2.0.0 before 2.0.7. Users are recommended to upgrade to version 1.3.7 or 2.0.7, which fixes the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache IoTDB

    From 1.0.0 · fixed in 1.3.7; From 2.0.0 · fixed in 2.0.7

  • org.apache.iotdb:iotdb-coreMaven

    From 1.0.0 · fixed in 1.3.7

  • org.apache.iotdb:iotdb-coreMaven

    From 2.0.0 · fixed in 2.0.7

References 1

lists.apache.org