Skip to main content
← All vulnerabilities
CVE-2026-24308GHSA-CRHR-QQJ8-RPXCBIT-ZOOKEEPER-2026-24308

Apache ZooKeeper: Sensitive information disclosure in client configuration handling

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.9.5, 3.8.6
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Improper handling of configuration values in ZKConfig in Apache ZooKeeper 3.8.5 and 3.9.4 on all platforms allows an attacker to expose sensitive information stored in client configuration in the client's logfile. Configuration values are exposed at INFO level logging rendering potential production systems affected by the issue. Users are recommended to upgrade to version 3.8.6 or 3.9.5 which fixes this issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • org.apache.zookeeper:zookeeper

    From 3.9.0 · through 3.9.4; From 3.8.0 · through 3.8.5

  • org.apache.zookeeper:zookeeperMaven

    From 3.9.0 · fixed in 3.9.5

  • org.apache.zookeeper:zookeeperMaven

    From 3.8.0 · fixed in 3.8.6

References 1

lists.apache.org