Skip to main content
← All vulnerabilities
CVE-2026-23897GHSA-MP6Q-XF9X-FWF7

Apollo Server is vulnerable to denial of service with `startStandaloneServer`

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.13.0, 5.4.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

Apollo Server is an open-source, spec-compliant GraphQL server that's compatible with any GraphQL client, including Apollo Client. In versions from 2.0.0 to 3.13.0, 4.2.0 to before 4.13.0, and 5.0.0 to before 5.4.0, the default configuration of startStandaloneServer from @apollo/server/standalone is vulnerable to denial of service (DoS) attacks through specially crafted request bodies with exotic character set encodings. This issue does not affect users that use @apollo/server as a dependency for integration packages, like @as-integrations/express5 or @as-integrations/next, only direct usage of startStandaloneServer.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • apollographql apollo-server

    From 2.0.0 · through 3.13.0; From 4.2.0 · fixed in 4.13.0; From 5.0.0 · fixed in 5.4.0

  • apollo-servernpm

    From 2.0.0 · through 3.13.0

  • @apollo/servernpm

    From 4.2.0 · fixed in 4.13.0

  • @apollo/servernpm

    From 5.0.0 · fixed in 5.4.0

References 3

GitHub · apollographql/apollo-server