Skip to main content
← All vulnerabilities
CVE-2026-23891GHSA-FC46-R95F-HQ7G

Decidim has a Cross-site scripting (XSS) vulnerability via user name field

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 0.31.1, 0.30.5
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Decidim is a participatory democracy framework. In versions below 0.30.5 and 0.31.0.rc1 through 0.31.0, a stored code execution vulnerability in the user name field allows a low-privileged attacker to execute arbitrary code in the context of any user who passively visits a comment page, resulting in high confidentiality and integrity impact across security boundaries. This issue has been fixed in versions 0.30.5 and 0.31.1.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • decidim decidim

    From 0.31.0.rc1 · fixed in 0.31.1; fixed in 0.30.5

  • decidim-coreRubyGems

    From 0.31.0.rc1 · fixed in 0.31.1

  • decidim-coreRubyGems

    fixed in 0.30.5

References 3

GitHub · decidim/decidim