Skip to main content
← All vulnerabilities
CVE-2026-23794GHSA-V84M-GFW5-HM2W

Apache Syncope: Reflected XSS on Enduser Login

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.0.16, 4.0.4
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Reflected XSS in Apache Syncope's Enduser Login page. An attacker that tricks a legitimate user into clicking a malicious link and logging in to Syncope Enduser could steal that user's credentials. This issue affects Apache Syncope: from 3.0 through 3.0.15, from 4.0 through 4.0.3. Users are recommended to upgrade to version 3.0.16 / 4.0.4, which fix this issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui

    From 3.0 · through 3.0.15; From 4.0 · through 4.0.3

  • org.apache.syncope.client.idrepo:syncope-client-idrepo-common-uiMaven

    From 3.0.0 · fixed in 3.0.16

  • org.apache.syncope.client.idrepo:syncope-client-idrepo-common-uiMaven

    From 4.0.0 · fixed in 4.0.4

References 1

lists.apache.org